Page 1 of 1

EZCast DUO old version (grey)

Posted: Tue Apr 09, 2019 4:05 pm
by Max Romeo
Hi there,

I have a challenge connecting a Macbook with a Samsung screen (or a Dell screen) using the EzCast DUO (old version).

The customer service suggested that it may have been a problem of firmware, hence I upgraded to the new firmware using my iPhone that it is perfectly recognised by the EzCast.

I am now going back and forth with the customer service that replies with 24h delay (!!) all the times without giving me an actual solution.

Every time that I connect the computer with the screen via EzCast Duo on the Samsung screen always appears the EzCast Portal: if I disconnect the cable, from the mac the screen goes black (hence, both computer and dongle are recognising the screen). The app on the computer doesn't seem to recognise the screen (VGA) tho: when I open the app and I click on USB connection a picture explaining how to connect cables appears however, the app doesn't seem to be able to mirror the screen of my mac, reason why I originally bought this product.

HELP! Any suggestion? Anything that I should be doing differently?

Max

Re: EZCast DUO old version (grey)

Posted: Thu Apr 18, 2019 11:13 am
by MissEZCast
Max Romeo wrote:Hi there,

I have a challenge connecting a Macbook with a Samsung screen (or a Dell screen) using the EzCast DUO (old version).

The customer service suggested that it may have been a problem of firmware, hence I upgraded to the new firmware using my iPhone that it is perfectly recognised by the EzCast.

I am now going back and forth with the customer service that replies with 24h delay (!!) all the times without giving me an actual solution.

Every time that I connect the computer with the screen via EzCast Duo on the Samsung screen always appears the EzCast Portal: if I disconnect the cable, from the mac the screen goes black (hence, both computer and dongle are recognising the screen). The app on the computer doesn't seem to recognise the screen (VGA) tho: when I open the app and I click on USB connection a picture explaining how to connect cables appears however, the app doesn't seem to be able to mirror the screen of my mac, reason why I originally bought this product.

HELP! Any suggestion? Anything that I should be doing differently?

Max


Please kindly check your email.