Page 1 of 1

Ezcast beam buffering issue

Posted: Tue Mar 19, 2019 10:49 am
by Sam Wong Teck Onn
Dear Ezcast Admin,
I just bought a Ezcast beam. Satisfied with the overall package.
However, when it comes to streaming, it suffers serious buffering issue. The video that I stream will run for 1-2 minutes and then start buffering for a few seconds, then play again, then buffering again. Practically it is unviewable using ezcast function. Then i try the ezcast mobile wire by connecting it to my smartphone with usb wire. The same thing happen again, serious buffering issue.

However, when i stream from chromecast that is connected to the beam HDMI input. The playback is butterly smooth.

By the way my beam SSID is 600D0788. Firmware is the latest as I have just updated the OS 2 days ago.

I have a Ezcast wire also, as you can see, I am a big fan of your company products. It does not have the buffering issue when i stream using it. Because of the ezcast wire user experience, I have decided to buy the beam.

Please help

Re: Ezcast beam buffering issue

Posted: Mon Mar 25, 2019 12:04 pm
by MissEZCast
Sam Wong Teck Onn wrote:Dear Ezcast Admin,
I just bought a Ezcast beam. Satisfied with the overall package.
However, when it comes to streaming, it suffers serious buffering issue. The video that I stream will run for 1-2 minutes and then start buffering for a few seconds, then play again, then buffering again. Practically it is unviewable using ezcast function. Then i try the ezcast mobile wire by connecting it to my smartphone with usb wire. The same thing happen again, serious buffering issue.

However, when i stream from chromecast that is connected to the beam HDMI input. The playback is butterly smooth.

By the way my beam SSID is 600D0788. Firmware is the latest as I have just updated the OS 2 days ago.

I have a Ezcast wire also, as you can see, I am a big fan of your company products. It does not have the buffering issue when i stream using it. Because of the ezcast wire user experience, I have decided to buy the beam.

Please help


Sorry for the inconvenience.
If you are using Android device, but while streaming it is always buffer and loading, we suggest your connect by EZMirror.
1. Please go to home page and go into EZMirror mode.
2. Turn on the EZMirror/Miracast of your Android device manually, please refer to our website: https://www.ezcast.com/usage/android/ezmirror
3. After connect by EZMirror/Miracast, the casting quality would be more better.

If still failed, please contact us and we would do our best to solve your problem.
Thanks for your patience.