EZCast 4k: frequent Miracast stutter/hitching, even under ideal circumstances

Discuss EZCast Questions & Bugs & Wishlist。

Moderator: Henry Chou

Jeff
Posts: 1
Joined: Tue Nov 28, 2017 12:02 am

EZCast 4k: frequent Miracast stutter/hitching, even under ideal circumstances

Postby Jeff » Tue Nov 28, 2017 12:24 am

Device: EZCast 4K
Firmware: 1.2129.1
Functions: Miracast (video playback over Android screen-sharing)
EZCast OS: Android (Samsung Galaxy S7)

Symptom:

Even under ideal circumstances, the playback of 720p YouTube videos over Miracast screen-sharing results in a frequent stutter/hitch (every ~3-4 seconds). There is a sub-second stall in video and audio, making playback unwatchable.

Notes:

In order to create the ideal environment for peak performance, the following measures were taken:

- EZCast 4K firmware updated to the latest version (1.2129.1).
- Samsung Galaxy S7 software updated to the latest version.
- EZCast 4K Wi-Fi disconnected from the local router.
- EZCast 4K Wi-Fi band set to 5GHz (40Hz bandwith, Auto channel select).
- EZCast 4K USB port plugged into a high quality mains power supply.
- EZCast 4K resolution set to 1280x720x60Hz.
- EZChannel turned off on the EZCast 4K.
- Broadcast device (Samsung Galaxy S7) placed next to the EZCast 4K receiver.

Symptom possibly a result of a local buffer being frequently cleared on the EZCast 4K device?

MissEZCast
Posts: 1074
Joined: Mon May 23, 2016 4:56 pm

Re: EZCast 4k: frequent Miracast stutter/hitching, even under ideal circumstances

Postby MissEZCast » Tue Nov 28, 2017 4:01 pm

Sorry for the inconvenience.
Can you please record a short video and send to support@iezvu.com for our checking? Or please provide us the video link.
Thanks for your help.


Return to “EZCast Questions & Bugs & Wishlist”