EZCAST4K dongle dead

Discuss EZCast Questions & Bugs & Wishlist。

Moderator: Henry Chou

Alex Handy
Posts: 6
Joined: Tue Jan 08, 2019 4:53 am

EZCAST4K dongle dead

Postby Alex Handy » Tue Jan 08, 2019 5:00 am

Hello everybody and happy past/present holidays...New Year!

I am posting this rather sad story here in hopes to receive any advice that could be tried in my situation.
In unfortunate circumstance and bad luck my trusty and loved dongle EZCAST4K has no longer showing bright blue indicator light.
I believe the trouble was when I plugged it into a TV set and it started picking up updates, however the TV screen had a problem and I did not realize the dongle was in the process of updating. I unplugged it and then when tried in another, perfectly working TV, I had no picture at all. The dongle was dead. You may be suggesting to use your repair tool software to re-store it. And, yes, I did it several times following your guides, with "success" message. But still, when powered, dongle only blinks blue light once dimly and then no blue light.
I am hoping to restore my EZ4K functionality... or send it in for repairs... The warranty period has probably been expired long time ago...

Thanks for your help.

Best wishes.

MissEZCast
Posts: 1074
Joined: Mon May 23, 2016 4:56 pm

Re: EZCAST4K dongle dead

Postby MissEZCast » Thu Jan 10, 2019 1:09 pm

Alex Handy wrote:Hello everybody and happy past/present holidays...New Year!

I am posting this rather sad story here in hopes to receive any advice that could be tried in my situation.
In unfortunate circumstance and bad luck my trusty and loved dongle EZCAST4K has no longer showing bright blue indicator light.
I believe the trouble was when I plugged it into a TV set and it started picking up updates, however the TV screen had a problem and I did not realize the dongle was in the process of updating. I unplugged it and then when tried in another, perfectly working TV, I had no picture at all. The dongle was dead. You may be suggesting to use your repair tool software to re-store it. And, yes, I did it several times following your guides, with "success" message. But still, when powered, dongle only blinks blue light once dimly and then no blue light.
I am hoping to restore my EZ4K functionality... or send it in for repairs... The warranty period has probably been expired long time ago...

Thanks for your help.

Best wishes.

Please try to use the repair tool to reset the 4k.
You can refer to https://www.ezcast.com/repair/ezcast/4k for downloading.
Thanks.

Alex Handy
Posts: 6
Joined: Tue Jan 08, 2019 4:53 am

Re: EZCAST4K dongle dead

Postby Alex Handy » Thu Jan 10, 2019 2:10 pm

Well, rather useless advice. Did you not read my sad story? I tried it already many times.
Is there a chance that I could have used wrong software (repair tool)? But it worked several times without a problem with SUCCESS message...
Am I screwed or what?
What is the indication of blue LED light absence when dongle is powered? And no HDMI output, no picture... I tried all power sources: USB, MHL, external USB adapter... no joy.

MissEZCast
Posts: 1074
Joined: Mon May 23, 2016 4:56 pm

Re: EZCAST4K dongle dead

Postby MissEZCast » Fri Jan 11, 2019 12:46 pm

Alex Handy wrote:Well, rather useless advice. Did you not read my sad story? I tried it already many times.
Is there a chance that I could have used wrong software (repair tool)? But it worked several times without a problem with SUCCESS message...
Am I screwed or what?
What is the indication of blue LED light absence when dongle is powered? And no HDMI output, no picture... I tried all power sources: USB, MHL, external USB adapter... no joy.

Sorry for the inconvenience.
It may cause to hardware damaged, so that repair tool couldn't repair your EZCast 4K dongle.
Thanks for your understanding.
Please kindly contact your seller and ask for help.

Alex Handy
Posts: 6
Joined: Tue Jan 08, 2019 4:53 am

Re: EZCAST4K dongle dead

Postby Alex Handy » Sun Jan 13, 2019 3:48 pm

I bought it from your web site directly. And I need it fixed or replaced. I am "kindly" contacting the seller right now... Strangely, any other HDMI device, I connected to the same TV set at the time, did not have any ill effects and worked fine afterwards. I think your EZcast4K is flawed if so easily damaged or screwed up by software update interruption. I believe there is something not right with your software repair tool, as I tried it on a few different systems with the same result - NO BLUE LIGHT ON DONGLE AFTER "SUCCESS" repair message...

MissEZCast
Posts: 1074
Joined: Mon May 23, 2016 4:56 pm

Re: EZCAST4K dongle dead

Postby MissEZCast » Tue Jan 15, 2019 2:16 pm

Alex Handy wrote:I bought it from your web site directly. And I need it fixed or replaced. I am "kindly" contacting the seller right now... Strangely, any other HDMI device, I connected to the same TV set at the time, did not have any ill effects and worked fine afterwards. I think your EZcast4K is flawed if so easily damaged or screwed up by software update interruption. I believe there is something not right with your software repair tool, as I tried it on a few different systems with the same result - NO BLUE LIGHT ON DONGLE AFTER "SUCCESS" repair message...


Sorry for the inconvenience. It's appreciated if you could record a short video of using the repair tool process, including selecting the EZCast repair tool option and send us the link or send email to support@ezcast.com directly. Using the wrong repair tool might also create the same issue.
Could you please also tell us the order number?
Thanks for your understanding and help.

Alex Handy
Posts: 6
Joined: Tue Jan 08, 2019 4:53 am

Re: EZCAST4K dongle dead

Postby Alex Handy » Wed Jan 30, 2019 11:21 am

Hello and I hope a good day finds you well,

You don't have to be sorry every time, it is counter-productive... Let's just get down to the bottom of the problem, investigate and find a remedy.
First off, I do not remember order number for my purchase. Could we go by any other IDs associated with the device? I also own your older version Tronsmart Mirror2TV, which is still in good shape. Please, advise.
Second off, If the repair software tool does not correctly detect a device and could possibly load up wrong firmware onto it, you should be very alarmed and getting to fixing it ASAP. On this note, I assume I did use correct software and if you don't believe my words, I can certainly spend time and do some video for you. I still believe the problem is in the FW, as nothing appears to be burnt/damaged with the dongle. And if you read my story, it happened because the auto-update was interrupted, though unintentionally.
This is it for now.

Alex Handy
Posts: 6
Joined: Tue Jan 08, 2019 4:53 am

Re: EZCAST4K dongle dead

Postby Alex Handy » Wed Jan 30, 2019 11:25 am

One more detail to add. My story needs to be forwarded to someone qualified to look into details, otherwise we are wasting time here...

MissEZCast
Posts: 1074
Joined: Mon May 23, 2016 4:56 pm

Re: EZCAST4K dongle dead

Postby MissEZCast » Thu Jan 31, 2019 12:20 pm

Alex Handy wrote:One more detail to add. My story needs to be forwarded to someone qualified to look into details, otherwise we are wasting time here...

If the repair tool is useless, we have no way to repair it.
Unplugged dongle while firmware upgrading may cause to damage the firmware or hardware of your dongle.
Sincerely sorry

Alex Handy
Posts: 6
Joined: Tue Jan 08, 2019 4:53 am

Re: EZCAST4K dongle dead

Postby Alex Handy » Thu Jan 31, 2019 2:52 pm

"Unplugged dongle may cause to damage the firmware or hardware of your dongle."
Seriously? I have no idea what you meant by this statement... It is crazy, to say the least... Are you sorry again?
I am sorry for your helpless SORRY...


Return to “EZCast Questions & Bugs & Wishlist”