Page 1 of 2

Problems with EZCast connection

Posted: Wed Dec 30, 2015 6:17 pm
by Jelle van Hemert
Hi,

I've a problem with the connection between the EZCast Dongle and my Ipad (iOS 9.2) and phone (Android 4.2.2).
According to the screen on my tv the EZcast makes good connection with the router (external USB power). The ipad and phone can indeed make connection with the EZCast SSID. This is also visible on the tv screen. But then the connection between Ipad and EZcast ssid is lost after a while, but the connection between EZcast dongle and router is still good (according to the tv-screen). Sometimes imedetiely, sometimes after trying to start EZCast Mirror. I've tried external USB power and usb power from the tv. I've tried to reinstall the EZCast app. I've tried different HDMI ports.I've tried to forget the Ezcast SSID and reconnect again. Do you have some other suggestions which I can try? Thank you.

Greetz,

Jelle

Re: Problems with EZCast connection

Posted: Wed Dec 30, 2015 6:35 pm
by Jelle van Hemert
I forgot an important fact:
My laptop can't connect with the EZCast SSID; wrong Password.
When I try to connect with the EZCast SSID with the Ipad or phone I often get the same error. But after trying different times it's working (mostly).

Re: Problems with EZCast connection

Posted: Wed Dec 30, 2015 7:06 pm
by Jelle van Hemert
Sorry;

Dongle’s SSID: EZCastmy-13591DC5
Functions: EZCast(Photo, Camera, Video, Web, ……), Airplay, EZMirror........
EZCast OS: Android, iOS & WindowseE
Symptom: connection lost from device and sometimes 'wrong password' when trying to connect with EZCast SSID

Re: Problems with EZCast connection

Posted: Fri Jan 01, 2016 6:21 pm
by Jelle van Hemert
Can anyone help me please?! That would be great!

Re: Problems with EZCast connection

Posted: Sat Jan 02, 2016 3:15 pm
by Henry Chou
Dear Jelle:

Sorry for the late reply and the inconvenience.
We suspect that this problem may come from WiFi interfering or crowded channel,
Please get the dongle as close to your WiFi router as possible because the WiFi performance could be reduced by distance, and please help to reboot your home router to rescan a cleaner channel. In addition, do not connect too many devices onto your home router when streaming or mirroring.
We also suggest use an external 5V/1A USB adapter instead of TV USB port to provide more stable power and WiFi connection.

Thanks and Regards,
EZCast service center: Henry (henrychou@iezvu.com)
EZCast Setup Demo: https://www.youtube.com/watch?v=JX1U1aAXt6M
EZCast Help: http://www.iezvu.com/os_help.php?l=en
EZCast FAQ: http://www.iezvu.com/help_faq.php?&l=en
EZCast Youtube channel: https://www.youtube.com/channel/UCrzaLj ... /playlists

Re: Problems with EZCast connection

Posted: Wed Jan 06, 2016 1:17 am
by Jelle van Hemert
Dear Henry,

Thanks for your advice!!
The dongle is placed very close to the router and I already use the usb-adapter instead of TV usb.
I shall try to reboot my router.

Greetz,
Jelle

Re: Problems with EZCast connection

Posted: Thu Dec 22, 2016 9:16 pm
by cimbom
Hello
I have same problem like that. Signal is very nice but i can not connect to the device. Sometimes i can connect but the ssid is changing to our wifi connection(our router).
How can i change the device channel and what can i do different?
Thanks

Re: Problems with EZCast connection

Posted: Mon Dec 26, 2016 10:26 am
by MissEZCast
Sorry for the inconvenience. EZCast dongles can not change WiFi Channel except EZCast pro dongles.
Thanks.

Re: Problems with EZCast connection

Posted: Wed May 24, 2017 3:38 pm
by Chrysa Paschal
Hello,

Windows 10, The wifi can NOT connect and most of the times not even show up. We cannot use USB cable. What are my options??????

Re: Problems with EZCast connection

Posted: Thu May 25, 2017 4:08 pm
by MissEZCast
Sorry, the issue may come from power insufficient. Please try to use your smartphone adapter instead of TV/Computer USB port to provide more stable power supply and WiFi connection.
If it still fails, please take a photo of your dongle's setup page shown on your TV for our further checking.
Thanks.